使用RVM安装ruby 2.3.2

安装ruby 2.3.2

rvm install 2.3.2 # 安装ruby 2.3.2
rvm use 2.3.1 --default # 使用ruby 2.3.2为默认版本
rvm list # 列出所有的安装的ruby版本,可以查看到默认版本是否设置成功

安装Rails出现的问题

安装rails

sudo gem install rails

无法安装出现异常

Rails 5 requires Ruby 2.2.2 or newer.
You're running ruby 2.0.0p648 (2015-12-16 revision 53162) [universal.x86_64-darwin15]
Please upgrade to Ruby 2.2.2 or newer to continue.

解决办法:

gem update --system # Update the RubyGems system software

无法运行rake db:migrate

出现异常rails fsevent: running worker failed: Resource temporarily unavailable

解决办法:

ps aux | grep fsevent_watch # See how many problems you got
ps aux | grep fsevent_watch | wc -l # Kill your problems
pkill -f fsevent_watch
ulimit -u # See your machine's limit